Τρίτη 16 Ιουλίου 2024 -

Δείτε το update που πρέπει να κάνετε όποιον browser κι αν χρησιμοποιείτε – Διορθώθηκε τεράστιο κενό ασφαλείας



Στην ανακάλυψη ενός τεράστιου κενού ασφαλείας, που επηρεάζει πρακτικά όλους τους browsers της αγοράς και χρησιμοποιείται από χάκερς, προχώρησε το Εθνικό Ινστιτούτο Προτύπων και Τεχνολογίας των ΗΠΑ (NIST)

Η αδυναμία αυτή επιτρέπει στους επιτιθέμενους να τρέξουν κακόβουλο κώδικα στους υπολογιστές των θυμάτων, έχοντας θεωρητικά τη δυνατότητα μέχρι και να πάρουν εξ ολοκλήρου τον έλεγχό τους.

Το NIST επισημαίνει πως το κενό ασφαλείας είναι εξαιρετικά σοβαρό, επηρεάζοντας πέρα από browsers και πολλά άλλα προγράμματα. Για παράδειγμα, διάφορες εφαρμογές που είναι φτιαγμένες με το Electron framework επηρεάζονται, με το εξαιρετικά δημοφιλές Signal να έχει κυκλοφορήσει ήδη το απαραίτητο patch. Ομοίως και εφαρμογές όπως τα Gimp, LibreOffice και Telegram επηρεάζονται, καθώς και πολλές Android και cross-platform εφαρμογές που είναι φτιαγμένες με το Flutter framework.

Το θέμα σχετίζεται με τον κώδικα που διαχειρίζεται το rendering των WebP εικόνων, που αρχίζουν τα τελευταία χρόνια να αντικαθιστούν μαζικά τις JPG και PNG εικόνες στο διαδίκτυο, μιας και το μέγεθός τους είναι σημαντικά μικρότερο, διατηρώντας αντίστοιχα επίπεδα ποιότητας.

Όπως και να ‘χει, μιας και οι browsers έρχονται συνήθως αντιμέτωποι με αυτού του τύπου τα αρχεία, προτείνεται να κάνετε όσο πιο άμεσα γίνεται το απαραίτητο update.

Οι εκδόσεις που είναι πλέον ασφαλείας και περιλαμβάνον το απαραίτητο fix είναι οι εξής:

Google Chrome 116.0.5846.187 (Mac / Linux)

Google Chrome 116.0.5845.187/.188 (Windows)

Firefox 117.0.1, Firefox ESR 102.15.1, Firefox ESR 115.2.1, Thunderbird 102.15.1, Thunderbird 115.2.2

Microsoft Edge 116.0.1938.81

Η Apple κυκλοφόρησε ήδη updates για τα δικά της προγράμματα νωρίτερα αυτή την εβδομάδα.